
Ortorektyfikacja w Metashape

Celem projektu jest opracowanie ortomozajki ze zdjęć lotniczych w dwóch wersjach:  true orto (odniesienie DSM)
oraz  klasyczna  ortomozajka  (odniesienie-DTM).  Linia  technologiczna  programu  Metashape  domyślnie  zakłada
tworzenie true ortho, model DSM powstaje na podstawie gęstej chmury punktów.  Wygenerowanie gęstej chmury
jest najbardziej czasochłonnym etapem tej technologii, dlatego w ćwiczeniu będzie wykonane dla mniejszej liczby
zdjęć niż etap początkowy czyli SfM.

Ćwiczenie podzielone jest na 2 części, w pierwszej używane są zdjęcia pionowe, w drugiej ukośne. Są to zdjęcia z
jednego  projektu  fotogrametrycznego,  przy  czym  kamera  do  zdjęć  pionowych  miała  f≈ 50 mm  a  kamery  do
ukośnych  f≈100 mm.  W  ćwiczeniu  nie  przewidziano  wyrównania  wspólnego,  które  można  przeprowadzić  po
wykonaniu aero-SfM oddzielne dla pionowych i ukośnych.  

Dane
wykorzystywane są zdjęcia  pionowe wykonane kamerę średnioformatową, o następującej konfiguracji:

• 4 szeregi po 4 zdjęcia, nalot wschód-zachód
• 3 szeregi po 4 zdjęcia, nalot północ-południe

oraz zdjęcia pod kątem 45O do pionu, w czterech kierunkach: wschód, zachód, północ, południe.

Na komputerach w sali  506 dane są w katalogu D > CFL2
Wszystkie wyniki należy zapisywać w katalogu D > CFL_users

część 1 – orto ze zdjęć pionowych

1. Uruchomienie Metashape 

File >  nowy projekt 

2. Wczytanie zdjęć Workflow > AddPhotos
> _NADIR wybrać wszystkie zdjęcia  (32)

3. Podanie parametrów kamery/kalibracji Tools > Camera Calibration  
frame, pix=0.0068 [mm]; f=50 [mm]; 
Fixed parameters: k3,k4,b1,b2,p3,p4 (czyli obliczane będą:  f, cx, cy, k1, k2, p1, p2)

4. Podanie właściwości danych Reference > Reference Settings    
układ wsp (x3):  PL-1992 (2180);
dokładność EOZ: mx=my=0.75 m; mz=1.25 m (wpis 0.75/1.25);    typ kątów om-fi-ka, m =0.1o

GCP: nieistotne, projekt będzie wykonany bez fotopunktów
dokładność tie mp=0.7 pix
śr. wys. fotografowania (capture distance) :        850  m

5. Import EOZ Reference > Import 
> EOZ  
Należy wczytać tylko X,Y,Z środków rzutów, pominąć kątowe EOZ

6. Aero - formowanie sieci zdjęć metodą SfM  Workflow > Align Photos 
General: Accuracy > Hight; 
 Preselection > Reference/Generic 

 Reset current alignment 
Advanced: Key  point limit: 40000 
 Tie point limit:    4000   (liczby większe niż w projekcie „Bochnia” gdyż liczona jest dystorsja)

Apply mask  Adaptive camera model fitting
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7. Filtracja tie Model > Gradual Selection   
W pierwszym etapie kasowane są wiązania które wystąpiły tylko na 2 zdjęciach:

> Image Count  odfiltrować tie które są tylko na 2 zdjęciach, skasować i Optimize (nie zmieniając parametrów)
W drugim:

> Reprojection Error – wykonać 2 iteracje, w każdej odfiltrować do 10% pkt ( po skasowaniu  > Optimize )

8. Ograniczenie liczby zdjęć 
utworzyć nowy pakiet danych, jako kopia pakietu z poprzednich etapów : 
Workspace  > Chunk > (PKM) > Duplicate 
jako aktywny Chunk wskazać  nowo utworzony (nazwać go np. 6 photo DSM)
skasować zdjęcia (Remove cameras) pozostawiając tylko  6 zdjęć, zgodnie z rozdziałem danych w tabeli 1. 

Przy zaznaczaniu pomocny jest podgląd pozycji kamer na tle tie points (widok z góry- klawisz „7”

9. Generowanie gęstej chmury punktów Workflow > Build Dense Cloud    
Quality > High
Depht Filtering > Moderate
Calculate  points color  > tak

zaobserwować raportowane  etapy generowania 

10. Generowanie modelu pokrycia terenu DSM Workflow > Build DEM 
ustawienia: Geographic (zachowanie CRS 2180), 
Source > Dense Interpolation > Enabled
pozostałe parametry – bz
wyświetlić:  Workspace > Chunk > DEM 

11. Generowanie ortomozajki  Workflow > Build Orthomosaic
 pix size 0.10 m  (program proponuje ok. 11 cm )
pozostałe parametry – bz 

12. Analiza ortomozajki
wyświetlić orto: Workspace > Chunk > Orthomosaic 
w pasku ikon pojawia się Show Seamlines 
skąd biorą się małe poligony?
Wykonać lokalną edycję linii mozaikowania : w obszarze wybranego małego poligonu narysować wielobok 
 Ortho > Draw polygon , PKM Assign Images
Opcja jest uruchamiana symbolicznie, ma pokazać możliwość wstawienia fragmentu z innego orto-obrazu niż 
wybrał program (który z reguły wybiera bardzo dobrze).

13. Eksport ortomozajki i ortoobrazów 
zapis w katalogu D > CFL_users
File > Export > Orthomosaic > JPEG/TIFF/PNG
Tiff compression Jpeg,  q=90, x Tiled x Tiff overviews o Big    o Alfa 
pozostałe parametry – bz
---------
w katalogu D>CFL_users  utworzyć katalog na orto-obrazy
File > Export > Orthophotos
Tiff compression Jpeg, q=90, x Tiled x Tiff overviews
> All cameras
pozostałe parametry – bz
po OK wybrać katalog do eksportu

14. Wczytanie NMT z innego źródła
DTM-5.tif  to model o rozdzielczości 5 m opracowany z wysokiej fotogrametrii, hybrydowo: siatka 20 m
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 z automatu, linie strukturalne i punkty charakterystyczne – manualny pomiar stereo.
Utworzyć nowy pakiet danych, jako kopia pakietu z 6. zdjęciami: Workspace  > Chunk > (PKM) > Duplicate 
jako aktywny Chunk wskazać  nowo utworzony (nazwać go np. 6 photo DTM-5 m)
File > Import DEM > DTM-5.tif

15. Generowanie ortomozajki 
  pix size  0.10 m 
pozostałe parametry - bz
Po wykonaniu wyświetlić orto: Workspace > Orthomosaic 
oraz wyświetlić linie mozaikowania Show Seamlines 
Sprawdzić czy linie mozaikowania przecinają budynki

16. Powtórne generowanie ortomozajki
powtórzyć  zaznaczając opcję  Refine seamlines (Blending mode)
Sprawdzić czy linie mozaikowania przecinają budynki
Uruchomić  generalizację linii mozaikowania: Tools > Orthomosaic >  Generate seamline 
przy współczynniku 1.5 lub 2. Po tym zabiegu linie mozaikowania można wyeksportować do pliku:
 Export > Shapes (jako shp wraz z labels & attributes)

17. Eksport ortomozajki i ortoobrazów 
zapis w katalogu D > CFL_users
File > Export > Orthomosaic > JPEG/TIFF/PNG
Tiff compression Jpeg, q=90, x Tiled x Tiff overviews o Big    o Alfa 
pozostałe parametry – bz
---------
w katalogu D > CFL_users  utworzyć katalog na ortoobrazy
File > Export > Orthophotos
Tiff compression Jpeg, q=90, x Tiled x Tiff overviews
x All cameras
pozostałe parametry – bz
po OK wybrać katalog do eksportu

18. Zapis projektu
Dla potrzeb opracowania projektu będą konieczne: raporty oraz ortomozajki i orto-obrazy dla dwóch 
przypadków:
a) orto/dsm 
b) orto/dtm z opcją refine seamlines (wraz z zapisem linii mozaikowania do pliku)

część 2 – orto ze zdjęć ukośnych   

1. Uruchomienie Metashape  
File >  wybrać projekt zapisany w części 1  (lub kontynuować projekt)
założenie nowego pakietu danych: Workspace> Add Chunk  (nazwać go np. ukosne)

2. Wczytanie zdjęć Workflow > AddPhotos
wybrać zdjęcia zgodnie z tabelą 1 (jeden z katalogów): _EAST, _SOUTH, _WEST, _NORD

3. Podanie parametrów kamery/kalibracji Tools > Camera Calibration  
frame, pix=0.0068 [mm]; f=100 [mm]; 
Fixed parameters: All
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Wyłączenie wszystkich  parametrów kalibracji będzie dotyczyło pierwszej iteracji SfM. Zdjęcia ukośne, bez 
podanych a priori kątów (om lub fi jest ok 45o), stanowią dla SfM trudne wyzwanie. Ograniczenie liczby 
niewiadomych jest w takich przypadkach korzystne. 

4. Podanie właściwości danych Reference > Reference Settings    
układ wsp (x3):  PL-1992 (2180);
dokładność EOZ: mx=my=1 m; mz=1.5 m (wpis 1/1.5);    typ kątów om-fi-ka, m =0.1o

GCP: nieistotne, projekt będzie wykonany bez fotopunktów
dokładność tie mp =1 pix
śr. wys. fotografowania (capture distance) :        850  m

5. Import EOZ Reference > Import 
dane w > EOZ  (odpowiednio east, west, nord, south)
Należy wczytać tylko X,Y,Z środków rzutów, pominąć kątowe EOZ
Problem z elementami kątowymi jest taki, że ich orientacja zależy od sposobu włożenia kamery do ramki, 
dlatego pomierzone kąty różnią się od właściwych o 90, 180o lub mają przeciwny znak. To można sprawdzić 
wpierw uruchamiając SfM z pominięciem kątów i potem porównać wartości szukając funkcji przeliczeniowej
do jednolitego odniesienia. W ćwiczeniu uwzględnianie pomierzonych kątów nie jest przewidziane.

6. Aero - formowanie sieci zdjęć metodą SfM  Workflow > Align Photos 
General: Accuracy > Hight; 
 Preselection > Reference/Generic 

 Reset current alignment 
Advanced: Key  point limit: 40000 
 Tie point limit:    4000   (liczby większe niż w projekcie „Bochnia” gdyż liczona jest dystorsja)

Apply mask  Adaptive camera model fitting

Jeśli estymowane wartości EOZ mają b. duże błędy  tj. MXYZ > 5 m, a kąty om/fi nie są ok 0/45 lub 45/0 z 
odchyleniem kilku stopni, to należy powtórzyć Align z nowymi ustawieniami
  Accuracy > Medium z aktywnym Reset current alignment 
Jeśli błędy dalej są duże to powtórzyć Align zmieniając dodatkowo:

Key  point limit: 20000 
 Tie point limit:    2000

Zmienić ustawienia kamery: Tools > Camera Calibration  
Fixed parameters:  cx,cy,k1,k2,k3,k4,b1,b2,p1,p2,p3,p4  (czyli obliczane będzie tylko f)
Uruchomić Optimize 

Optimize Camera Alignmnet , dopuścić liczenie  f

7. Filtracja tie Model > Gradual Selection
> Reprojection Error – wykonać 2-3 iteracje, w każdej odfiltrować do 5% pkt ( po skasowaniu  > Optimize )

8. Generowanie gęstej chmury punktów Workflow > Build Dense Cloud 
Quality > Medium
Depht Filtering > Moderate
Calculate  points color  > tak
Przeglądnąć chmurę, czym różni się od gęstej chmury z pionowych zdjęć lotniczych? Czy chmury się dublują
 czy uzupełniają? 

9. Generowanie modelu pokrycia terenu DSM Workflow > Build DEM 
ustawienia: Geographic (zachowanie CRS 2180), 
Source > Dense Interpolation > Enabled
pozostałe parametry – bz
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10. Generowanie ortomozajki  Workflow > Build Orthomosaic
 pix size  0.10 m 
pozostałe parametry - bz
Po wykonaniu wyświetlić orto: Workspace > Orthomosaic 
oraz  linie mozaikowania Show Seamlines 
Jaka jest jakość i przydatność tego opracowania?

11. Wczytanie NMT z innego źródła
Utworzyć nowy pakiet danych jako kopia pakietu opracowanego w poprzednich etapach: 
Workspace  > Chunk > (PKM) > Duplicate 
Nowo utworzony pakiet nazwać  np. ukosne-DTM-5 m
Wczytać model    File > Import DEM> DTM-5.tif

12. Generowanie ortomozajki
 pix size  0.10 m 
zaznaczyć opcję  Refine seamlines (Blending mode)
Sprawdzić czy linie mozaikowania przecinają budynki

13. Eksport ortomozajki i ortoobrazów 
File > Export > Orthomosaic
Tiff compression Jpeg, q=90, x Tiled x Tiff overviews o Big    o Alfa 
pozostałe parametry – bz

w katalogu D>CFL_users  utworzyć katalog na ortoobrazy
File > Export > Orthophotos
Tiff compression Jpeg, q=90, x Tiled x Tiff overviews o Big    o Alfa 
pozostałe parametry – bz
po OK wskazać katalog do eksportu

14. Zapis projektu
dla potrzeb opracowania projektu będą konieczne: raport oraz ortomozajka uzyskana z DTM-5 z opcją refine 
seamlines 

Opracowanie wyników

Opracować sprawozdanie, w którym wpierw krótko opisać co było przedmiotem  projektu ( 3000 - 4000 znaków). W 
opisie wykorzystać raporty generowane przez program dla poszczególnych chunk-ów (same raporty nie wchodzą do 
sprawozdania). W dalszej części sprawozdania ustosunkować się do następujących kwestii:

Pola martwe na orto-obrazach

Dotyczy orto-obrazów ze zdjęć pionowych z modelem DSM. Pola martwe są reprezentowane przez piksele o 
wartościach 255,255,255. Badanie pól martwych wystarczy przeprowadzić dla  jednego kanału obrazu RGB (np. kanału 
1).

Do badania wybrać  orto-obraz wykonany ze zdjęcia środkowego  w szeregu oraz jego odpowiednik z drugiego szeregu.

Dodać orto-obrazy algebraicznie  wskazując z każdego kanał 1. Przyciąć sumę do prostokąta pokrywającego oba orto-
obrazy (z wykluczeniem marginesów bez tekstury). Identycznie przyciąć orto-obrazy z których była liczona suma.

Określić ile jest w każdym (przyciętym) obrazie pikseli reprezentujących pola martwe. Dla obrazu sumarycznego pole 
martwe ma wartość 510. 

Do wykonania zadania potrzebne narzędzie GIS które pozwala przyciąć obraz do tego samego obszaru prostokątnego, 
podać ile jest pikseli o poszczególnych jasnościach; wykonać algebrę map.
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W przypadku QGIS: 

• algebra map: Raster> kalkulator

• przycięcie: Raster > Cięcie > Przytnij raster do zasięgu (pierwsze wycięcie > wybierz zasięg w widoku; kolejne 
dwa wycięcia: użyj zasięgu warstwy)

• liczba pikseli 255 lub 510: Processing > Raster analiza > Raport unikalnych wartości

Konflikty linii mozaikowania

Dotyczy ortomozajki ze zdjęć pionowych i ukośnych uzyskanych dla  modelu DTM-5 (w obu wypadkach gdy była 
włączona opcja Refine seamlines). Konflikt oznacza przecięcie przez linię mozaikowania budynku lub drzew. Ocenić 
wizualnie, oszacować liczbę i pokazać min 1 przykład dla obu ortomozajek.

Mapa przeglądowa mozajkowania

Dotyczy orto ze zdjęć pionowych dla  modelu DTM-5.

Mapa ma pokazywać przebieg linii mozajkowania, nazwy orto-obrazów wewnątrz obszarów ograniczonych liniami, na 
tle ortomozajki. Aby uzyskać taki efekt należy poddać edycji linie mozaikowania (wraz z innymi danymi) 
wyeksportowane do pliku shp.

Pokrycie podłużne i poprzeczne 

Określić średnie pokrycie podłużne i poprzeczne zdjęć pionowych oraz ukośnych 

Dokładność orto-obrazów i ortomozajek

Oszacować dokładność orto-obrazów/dtm5 ze zdjęć pionowych przez porównanie położenia co najmniej 10 punktów
załamania konturów budynków względem BDOt10k. Do pomiaru wybierać takie miejsca na orto-obrazach w których
widać  przyziemia  budynków.  Punkty  powinny  być  rozmieszone  w  miarę  równomiernie  na  obszarze  ortomozajki.
Zestawić różnice dX i dY w tabeli oraz podać wartość średnią, średni błąd kwadratowy wsp. X i Y oraz położenia XY
(RMSEx, RMSEx, RMSExy), wraz z mapką prezentującą położenie punktów w obszarze ortomozajki. Ustosunkować się
do występowania czynnika systematycznego odchyłek.

Oszacować dokładność ortomozajek/dsm ze zdjęć pionowych oraz ortomozajek/dtm5 z ukośnych przez porównanie
położenia co najmniej 10 szczegółów względem ortomozajki/dtm5 ze zdjęć pionowych. Zestawić różnice dX i dY w
tabeli oraz podać wartość średnią, średni błąd kwadratowy wsp. X i Y  oraz położenia XY (RMSEx, RMSEx, RMSExy).
Ustosunkować się do występowania czynnika systematycznego odchyłek.

Przesłać sprawozdanie w pliku: cfl-orto-mshp-nazwisko.pdf 

Załączniki  ↓ 
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Tabela 1. Przydział zdjęć

Student Pomocnicze numery 
zdjęć pionowych 

Zdjęcia  ukośne Student Pomocnicze numery 
zdjęć pionowych

Zdjęcia  ukośne

1. 1,2,3,6,7,8 east 16 7,8,12,13,18,19 east

2. 2,3,4,7,8,9 south 17 8,9,13,14,17,18 south

3. 3,4,5,8,9,10 west 18 21,22,23,26,27,28 west

4. 4,5,9,10,14,15 nord 19 22,23,24,25,26,27 nord

5. 6,7,8,11,12,13 east 20 25,26,27,30,31,32 east

6. 7,8,9,12,13,14 south 21 21,28,29,22,27,30 south

7. 8,9,10,13,14,15 west 22 22,27,30,23,26,31 west

8. 9,10,14,15,17,16 nord 23 23,26,31,24,25,32 nord

9. 11,12,13,18,19,20 east 24 22,27,23,26,24,25 east

10. 12,13,14,17,18,19 south 25 27,30,26,31,25,32 west

11. 13,14,15,16,17,18 west 26 2,3,4,7,8,9 nord

12. 3,4,8,9,13,14 nord 27 3,4,5,8,9,10 east

13. 2,3,7,8,12,13 east 28 4,5,9,10,14,15 west

14. 1,2,6,7,11,12 south 29 6,7,8,11,12,13 nord

15. 6,7,11,12,19,20 west 30 7,8,9,12,13,14 east

Tabela 2. Przyporządkowanie zdjęć do numerów pomocniczych

Nr pomocnicze Zdjęcie Nr pomocnicze Zdjęcie
1 011_1722.tif 17 014_1880.tif
2 011_1723.tif 18 014_1881.tif
3 011_1724.tif 19 014_1882.tif
4 011_1725.tif 20 014_1883.tif
5 011_1726.tif 21 036_0607.tif
6 012_1791.tif 22 036_0608.tif
7 012_1792.tif 23 036_0609.tif
8 012_1793.tif 24 036_0610.tif
9 012_1794.tif 25 037_0645.tif

10 012_1795.tif 26 037_0646.tif
11 013_1848.tif 27 037_0647.tif
12 013_1849.tif 28 037_0648.tif
13 013_1850.tif 29 038_0679.tif
14 013_1851.tif 30 038_0680.tif
15 013_1852.tif 31 038_0681.tif
16 014_1879.tif 32 038_0682.tif

KPyka,  GiFT > CFL > Orto w Metashape                                   30.10.2019 7


