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Wstęp do środowiska ILWIS  

Celem zajęć jest zapoznanie się ze środowiskiem ILWIS. Nazwa ILWIS pochodzi od Integrated Land and Water 

Information System. Jest to system GIS opracowany przez International Institute for Aerospace Survey and 

Earth Sciences (ITC). ILWIS zawiera szereg funkcji, które pozwalają na tworzenie, zarządzanie, analizowanie i 

prezentowanie danych przestrzennych.  

Informacje o programie ILWIS, binaria oraz dokumentację można znaleźć na stronie:  

http://52north.org/index.php?option=com_content&view=category&layout=blog&id=33&Itemid=67 

[http://52north.org /index.php?option=com_content&view=category&layout=blog&id=33&Itemid=67]  

 

Pozyskiwanie danych  

Dane wprowadzane do GIS pochodzić mogą 

z bezpośrednich pomiarów terenowych, skanowania 

i digitalizacji istniejących papierowych materiałów 

kartograficznych oraz dzięki zdalnej rejestracji – 

teledetekcji i fotogrametrii. Do systemu wprowadzane 

mogą być również dane istniejące w postaci tabel, 

wykresów, rysunków, a także korzystać można 

z istniejących już zbiorów danych cyfrowych.  

 

Zdalne dane obrazowe odgrywają coraz większa rolę w 

zasilaniu bazy danych GIS – rośnie ilość 

i różnorodność źródeł danych. Poprawia się ich jakość 

geometryczna i spektralna, rośnie dostępność. Dlatego 

większość pakietów GIS posiada wyspecjalizowane 

moduły do wstępnego przetwarzania i wzmacniania 

treści informacyjnej z obrazów teledetekcyjnych. Tak 

jest również w przypadku oprogramowania ILWIS.  

Dlatego zarówno ćwiczenia z zakresu teledetekcji, jak 

i analiz rastrowych, można zrealizować w jego 

środowisku. 

 

Reprezentacja danych  

W systemach typu GIS dane zorganizowane są w postaci 

warstw tematycznych. Każda warstwa pokrywa ten sam 

fragment terenu i zawiera wyłącznie jeden rodzaj danych, 

np. sposób użytkowania terenu, drogi, wysokość nad 

poziom morza, szpitale, gęstość zaludnienia itp. 

Warstwami mogą być również np. obrazy teledetekcyjne 

czy fotogrametryczne. Ten sposób organizacji danych 

porównywany jest często do zestawu map tematycznych 

narysowanych na przeźroczystej folii, które można na 

siebie nakładać.  

Ze względu na sposób reprezentacji danych systemy 

GISowskie można podzielić na dwie grupy: systemy 

rastrowe i systemy wektorowe. ILWIS jest programem 

pracujący głównie na danych rastrowych, umożliwia 

również wizualizację danych wektorowych oraz konwersje 

pomiędzy danymi w postaci wektorowej i rastrowej. 

Typ danych rastrowych używa macierzy komórek, które zawierają pewne wartości liczbowe, do reprezentacji 

obiektów przestrzennych. Każda komórka, nazywana także pikselem, jest zlokalizowana przestrzennie, a jej 

wartości mogą mieć wiele znaczeń: może odzwierciedlać kolor mapy, temperaturę, sposób użytkowania terenu 

lub jego wysokość. 
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Dane do ćwiczenia (cześć 1) 

Mapy rastrowe:  

mu_k  - mapa użytkowania terenu okolic Krakowa oraz paleta o tej samej nazwie, 

dem_k  - mapa zawierająca model wysokościowy okolic Krakowa. 

landuse  - mapa użytkowania terenu 

Mapy wektorowe:  

countur  - przykładowa mapa wektorowa zawierająca obiekty liniowe 

landuse  - przykładowa mapa wektorowa zawierająca poligony (obiekty obszarowe, powierzchniowe) 

 

Główne okno  

Uruchom program ILWIS. Otworzy się główne okno programu, przy pomocy którego można zarządzać danymi, 
na których pracujemy oraz uruchamiać wszystkie funkcje.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Pasek standardowych ikon pozwala na następujące operacje: 

 - wyszukanie na dysku i otwarcie katalogu z danymi 

 - wyświetlenie mapy oraz dowolnego obiektu z wybranego katalogu na dysku 

 - uruchomienie narzędzie informacji o punkcie 

 - kopiowanie mapy / dowolnego obiektu 

 - wklejanie mapy / dowolnego obiektu 

 - usuwanie pliku 

 -  wyświetlanie informacji (właściwości) o mapie / obiekcie  
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ILWIS operuje na plikach zawierających różne rodzaje danych. Każdy typ jest wyróżniany przy pomocy 

odpowiedniej ikony. Najważniejsze z nich, to:  

 - mapy rastrowe  

 - mapy wektorowe zawierające obiekty powierzchniowe 

 - mapy wektorowe zawierające obiekty liniowe 

 - mapy wektorowe zawierające obiekty punktowe 

 - tabele zawierające informacje o możliwych wartościach atrybutów na mapach  

 - domeny zawierające informacje o zawartości map  

 - palety (reprezentacje barwne)  

 - układy współrzędnych 

 - georeferencje  

 

• Aby wyświetlić dowolną mapę w systemie ILWIS należy dwukrotnie kliknąć na nazwę mapy w głównym 

oknie programu.  

• Nawigując pomiędzy 

katalogami przejdź do 

folderu z danymi i 

otwórz mapę rastrową 

mu_k zdefiniuj parame-

try wyświetlania mapy - 

do reprezentacji barw-

nej powinna zostać 

użyta paleta mu_k.  

• W oknie mapy sprawdź 

operacje na widoku 

mapy: powiększanie, 

pomniejszanie, przesu-

wanie, pomiar odleg-

łości, pomiar wartości 

atrybutu piksela  

 
• dostosowywanie do zasięgu mapy, a następnie klikając lewym przyciskiem myszy po mapie sprawdź jaka 

wartość kryje się pod poszczególnymi kolorami mapy Sprawdź jakie cechy ma wyświetlana mapa. 

Dwukrotnie klikając w legendzie na pozycję Properties dla mapy mu_k, lub wybierając z menu 

File→Properties odczytaj następujące parametry:  

o ilość wierszy i kolumn na mapie rastrowej  

o rozmiar piksele - rozdzielczość mapy  

o typ układu współrzędnych  

o minimalne i maksymalne wartości współrzędnych X i Y  

o ilość pamięci zarezerwowanej dla jednego piksela  

 

• W kolejnym kroku wyświetl mapę dem_k. Porównaj parametry obu map map  

• W dowolnym oknie mapy wypróbuj narzędzie do odczytywania wartości pikseli:  

File→Open Pixel Information  

• Na mapie dem_k znajdź wysokość terenu w punktach o następujących współrzędnych, odczytaj także 

numer wiersza i kolumny szukanego punktu:  

o (4551819.00,5404322.00)  

o (4549615.00,5409923.00)  
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Domeny  

Jak zauważyłeś jednostki mapy mu_k są opisane przy pomocy klas, na przykład: grunty orne, parki i sady, 

zabudowa miejska, itd. Lista klas, które mogą pojawić się na mapie nazwana jest domeną. Domena opisuje 

jakie wartości mogą pojawiać się na mapie, w tabeli, bądź w kolumnie. Podstawowe typy domen w systemie 

ILWIS to:  

o klasy (class) - używane dla danych, które można opisać przy pomocą klas, tak jak mapa użytkowania 

terenu  

o identyfikatory - przydatne dla danych zawierających unikatowe identyfikatory  

o wartości (value) - używane dla danych, które są wynikiem pomiarów, obliczeń, tak jak mapa 

wysokości terenu, powierzchnia terenu  

o wartości dodatnich (distance) - używane dla danych, które są wynikiem pomiarów związanych z 

odległością  

o wartości logiczne (bool) - przydatne dla danych, które mogą przyjmować tylko dwie wartości: prawda 

lub fałsz  

o image - domena przydatna dla obrazów satelitarnych lub zeskanowanych zdjęć lotniczych, gdzie dane 

mogą przyjmować wartości od 0 do 255  

Wyświetl i porównaj domeny dla map mu_k i dem_k. Sprawdź jakiego typu są te domeny.  

 

Mapy wektorowe w ILWISie  

ILWIS umożliwia posiada zestaw funkcji pozwalających na pracę z mapami wektorowymi. W tym rozdziale 
przyjrzymy się sposobowi prezentacji danych wektorowych w ILWISie.  

• Włącz mapę rastrową landuse   

• Przy pomocy menu Layers→Add Layer dodaj poligonową warstwę wektorową landuse do mapy  

• Dodaj liniową warstwę wektorową 

• Zapoznaj się z opcjami prezentacji map wektorowych, spróbuj zmodyfikować kolorystykę, kolejność i 

widoczność warstw, itd.  

 

Dane do ćwiczenia (cześć 2) 

Mapa rastrowe:  

tmb1  - przykładowy obraz satelitarny, kanał niebieski 

Mapy wektorowe:  

countur  - przykładowa mapa wektorowa zawierająca obiekty liniowe 

landuse  - przykładowa mapa wektorowa zawierająca poligony (obiekty obszarowe, powierzchniowe) 

rainfall  - przykładowa mapa wektorowa zawierająca obiekty punktowe 

 

Palety – reprezentacja danych 

• Wyświetl mapę wektorową Landuse. Zwróć 

uwagę na ubogą kolorystykę mapy. 

• Stwórz paletę dla domeny Landuse. Kliknij 

prawym przyciskiem myszy na domenie i z 

menu kontekstowego wybierz Create 

Representation. W nowej palecie osobne 

kolory powinny przypadać dla różnych 

wartości w domenie.  

• Wyświetl mapę wektorową countur. Mapa 

zawiera warstwice wraz z ich wysokościami. Sprawdź minimalne i maksymalne wartości oraz domenę 

mapy. Stwórz paletę dla domeny mapy countur tak, żeby barwy niebieskie i zielone odpowiadały 

najniższym wysokościom, a barwy żółte, czerwone i brązowe największym wysokościom. 
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Przygotowanie wielowarstwowych map  

• Otwórz mapę tmb1, dobierając odpowiednie parametry prezentacji. Zwróć uwagę na zakres wartości 

pikseli na mapie (można sprawdzić w legendzie, w pozycji Properties, lub w parametrach wyświetlania 

mapy Display Options) oraz spróbuj zmodyfikować parametry wzmocnienia histogramu (dwie wartości 

pojawiające się przy stretch w oknie definiującym parametry wyświetlania mapy). Spróbuj zmienić paletę 

(Representation) dla mapy rastrowej.  

• Nałóż na zdjęcie satelitarne wektorową warstwę przedstawiającą sposób użytkowania terenu, użyj palety 

przygotowanej na zajęciach.  

• Przy pomocy opcji Transparent dobierz odpowiedni poziom przeźroczystości, tak aby mapa była czytelna 

Zmodyfikuj sposób wyświetlania granic obszarów na mapie wektorowej:  

o Boundaries only wyświetla tylko granice obszarów, wypełnienia są niewidoczne  

o Hide superfluous Boundaries ukrywa zbędne granice pomiędzy obszarami tego samego typu  

o Boundary Color oraz Boundary Width pozwala na określenie stylu rysowania granic obszarów - koloru 

oraz szerokości lini.  

• Nałóż na zdjęcie satelitarne warstwę countur przedstawiającą warstwice. Wybierz paletę przygotowaną w 

trakcie zajęć.  

• Dobierz parametry wyświetlania warstwy, tak, żeby mapa była jak najbardziej czytelna. Jeżeli trzeba 

zmodyfikuj paletę lub kolejność warstw.  

• Dodaj do mapy warstwę Rainfall. Określ dla warstwy rodzaj wykorzystywanych symboli oraz sposób 

etykietowania.  

 

Przygotowanie wydruku  

• W oknie, w którym została przygotowana mapa wybierz File→Create Layout  

• Przygotuj szablon wydruku, w którym będą znajdować się następujące elementy:  

o tytuł mapy - przy pomocy narzędzia Insert→Text… można do widoku wydruku dodawać dowolne 

napisy, np. tytuł mapy. Dostępne są następujące opcje:  

� Alignment pozwala na ustawienie wyrównania tekstu: do lewej (Left), do prawej (Right) oraz na 

środek (Center)  

� Color to kolor czcionki  

� Font Name umożliwia wybór kroju czcionki  

� Font Size pozwala na ustawienie wielkości liter napisu  

� Rotation pozwala na ustawienie, czy napis ma się pojawiać w pionie, poziomie, czy pod określonym 

kątem  

� Bold - czcionka pogrubiona, Italic - kursywa,  

� Transparent - pozwala włączyć przeźroczystość tła napisów  

 

o legenda - wykorzystując narzędzie Insert→Legend… można dodać do wydruku legendę mapy. 

Dostępne są opcje (w zależności od domeny, parametry mogą być różne):  

� Number of Columns - określa na ile kolumn zostanie podzielona legenda  

� Code - jeżeli zostanie włączona, w legendzie pojawi się kod obiektu lub gdy włączymy  

� Name - nazwa lub gdy włączymy  

� Description - opis,  

� przy pomocy przycisków „<” oraz „>” można wybrać pozycje, które pojawią się w legendzie,  

� Font Name umożliwia wybór kroju czcionki w opisie legendy  

� Font Size pozwala na ustawienie wielkości liter w legendzie  

� Bold - czcionka pogrubiona, Italic - kursywa  

� parametry Box Height, Box Width/Height Ratio, Extra Height pozwalają na ustawienie sposobu 
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wyświetlania ramki legendy  

� Transparent - ustawia przeźroczystość legendy  

� MinMax -umożliwia określenie maksymalnej i minimalnej wartości, jaka będzie prezentowana na 

legendzie  

� Upward - czy wartości w legendzie będą uporządkowane rosnąco czy malejąco  

� Ratio - określa rozmiar legendy  

 

o linia skali - aby wstawić linie skali, należy użyć Insert→Scale Bar. Ważniejsze opcje:  

� Blocked - linia skali w postaci bloczka lub Line - linii,  

� Nr of Intervals to ilość przedziałów, jakie zostaną umieszczone na linii skali  

� Interval Length długość przedziałów określona w jednostkach mapy,  

� 1st interval divided into smaller parts pozwala ustalenie, czy pierwszy przedział zostanie podzielony 

na mniejsze części  

� Uniet Indication jeżeli zostanie włączone, to przy linii skali pojawią się jednostki, opcja Use km 

wymusza kilometry jako jednostki  

� Color to kolor czcionki  

� Font Name umożliwia wybór kroju czcionki  

� Font Size pozwala na ustawienie wielkości liter  

� Bold - czcionka pogrubiona, Italic - kursywa,  

� Transparent - pozwala włączyć przeźroczystość tła napisów  

 

o informacja o skali mapy - aby wstawić do mapy informacje o jej skali wystarczy użyć narzędzia 

Insert→Scale Text. Opcje takie same jak w przypadku wstawiania do wydruku mapy napisów. 

 

o strzałka północy - aby na mapie był widoczny kierunek północy należy wykorzystać Insert→North 

Arrow…. Podstawowe opcje to:  

� Simple prosta strzałka pokazująca północ  

� Cross strzałka pokazująca północ oraz linia dla kierunku wschód – zachód 

� Wing skrzydło wskazujące kierunek północy na mapie  

� Compass kierunki na mapie wskazuje róża wiatrów  

� Text jeżeli ta opcja zostanie włączona do strzałki zostanie dodana litera N, wskazująca kierunek 

północy, jeżeli dodatkowo wybierzemy All Sides to pojawią się opisy pozostałych kierunków - S, E, 

W.  

� Color to kolor czcionki  

� Font Name umożliwia wybór kroju czcionki  

� Font Size pozwala na ustawienie wielkości 

liter  

� Bold - czcionka pogrubiona, Italic - 

kursywa,  

� Transparent - pozwala włączyć 

przeźroczystość tła napisów  

�  

o siatka oraz marginalia - należy wybrać opcję 

Insert→Map Border. Można określić, czy na 

mapie będzie widoczna siatka, współrzędne 

rogów mapy, opisy na obrzeżach mapy  

o plik graficzny - przy pomocy narzędzia 

Insert→Bitmap/Picture… można wstawić  

do wydruku dowolny plik graficzny. Obrazek 

może przedstawiać np. logo firmy, która 

przygotowała mapę.  


