
Ortorektyfikacja w Metashape

Celem projektu jest opracowanie:

A) ortorektyfikacja pionowych zdjęć lotniczych w dwóch wersjach:  true orto (odniesienie DSM) oraz klasycznej
(odniesienie-DTM),

B) ortorektyfikacja ukośnych zdjęć lotniczych w wersji klasycznej (na DTM).

Program Metashape  domyślnie  zakłada  tworzenie  true  ortho,  model  DSM powstaje  na  podstawie  gęstej  chmury
punktów. Wygenerowanie gęstej chmury jest najbardziej czasochłonnym etapem tej technologii, dlatego w ćwiczeniu
będzie wykonane dla mniejszej liczby zdjęć niż etap początkowy czyli wyrównanie bloku.

Orto w Metashape można wykonać na podstawie DTM z innego źródła, co przyspiesza proces ale przedstawia obiekty
wystające  nad  teren  z  przesunięciem  radialnym.  Będzie  wykorzystany model  o  rozdzielczości  5  m opracowany  z
wysokiej  fotogrametrii:  siatka 20 m z  automatu,  linie strukturalne i  punkty charakterystyczne – manualny pomiar
stereo.

Metashape stosuje dla DSM i DTM ogólny termin - DEM. 

W ćwiczeniu używane są zdjęcia pionowe oraz ukośne. Są to zdjęcia z jednego projektu fotogrametrycznego, przy czym
kamera do zdjęć pionowych miała f≈ 50 mm a kamery do ukośnych f≈100 mm (system złożony z pięciu kamer). 

Temat  jest  skoncentrowany  na  ortorektyfikacji,  dlatego  wyrównanie  bloków  zdjęć  będzie  uproszczone  do
minimum: 

• z pomiarów GPS/INS będą wykorzystane tylko współrzędne środków rzutów (kąty w tym projekcie są niskiej
jakości),

• nie będą stosowane fotopunkty.

Dane
wykorzystywane są zdjęcia  wykonane układem 3 kamer (1 pionowe  oraz 2  ukośne z odchyleniem 45O do pionu). Lot
fotogrametryczny  był  w  2  kierunkach  wschód-zachód  i  północ-południe,  co  nadało  kamerom  ukośnym  kierunki
patrzenia: wschód, zachód, północ, południe.

Na komputerach w sali 408 dane są w katalogu D > CFL2 > orto-nu 
Wszystkie wyniki należy zapisywać w katalogu D > CFL2 > orto-nu >  nazwisko

część A – orto ze zdjęć pionowych

1. Uruchomienie Metashape 

File >  nowy projekt 

2. Wczytanie zdjęć Workflow > AddPhotos
> _NADIR wybrać wszystkie zdjęcia  (32)

3. Podanie parametrów kamery/kalibracji Tools > Camera Calibration  
frame, pix=0.0068 [mm]; f=50 [mm]; 
obliczane będą:  f, cx, cy, k1, k2, p1, p2, pozostałe parametry =0  (Fixed parameters)

4. Podanie właściwości danych Reference > Reference Settings    
układ wsp (x3):  PL-1992 (2180);
dokładność EOZ: mx=my=0.5 m; mz=1.0 m (wpis 0.5/1.0);    typ kątów i dokładność (om-fi-ka, m =...)- nieistotne 
GCP: projekt będzie wykonany bez fotopunktów
dokładność tie mp=0.7 pix
śr. wys. fotografowania (capture distance) :   850  m
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5. Import EOZ Reference > Import 
> EOZ >  nadir.txt  
Należy wczytać tylko X,Y,Z środków rzutów, pominąć kątowe EOZ
pamiętać o poprawnym ustawieniu osi układu współrzędnych, w pliku nie ma nagłówka -zaznaczyć czytanie od 1. 
wiersza

6. Aero - formowanie sieci zdjęć metodą SfM  Workflow > Align Photos 
General: Accuracy > Hight; 
 Preselection > Reference/Generic 

 Reset current alignment 
Advanced: Key  point limit: 40000 
 Tie point limit:    4000   (liczby duże adekwatne do przypadku gdy liczona jest dystorsja)

Apply mask  Adaptive camera model fitting

7. Filtracja tie Model > Gradual Selection 
użyć wszystkich opcji z wyjątkiem image count, zalecana kolejność: 
>  Projection Accuracy (filtracja punktów „grubych”)  odfiltrować max 100 pkt
>  Reconstruction uncertainty (filtracja punktów o małej precyzji przecięcia promieni)  odfiltrować max 100 pkt, 
>  image count (filtracja tie o małej liczbie promieni), sprawdzić ile pkt ma tylko 2 przecięcia, odfiltrować gdy ich 
liczba jest mniejsza niż 30% wszystkich 
 > Reprojection Error – wykonać 2 iteracje, w każdej odfiltrować do 5% pkt 

   po każdym etapie filtracji skasować zaznaczone i uruchomić  > Optimize 

8. Ograniczenie liczby zdjęć 
utworzyć nowy pakiet danych, jako kopia pakietu z poprzednich etapów : 
Workspace  > Chunk > (PKM) > Duplicate 
jako aktywny Chunk wskazać  nowo utworzony (nazwać go np. 6 photo DSM)
skasować zdjęcia (Remove cameras) pozostawiając tylko  6 zdjęć, zgodnie z rozdziałem danych podanym w 
załaczniku. 

Przy zaznaczaniu pomocny jest podgląd pozycji kamer na tle tie points (widok z góry- klawisz „7”)

9. Generowanie gęstej chmury punktów Workflow > Build Dense Cloud    
Quality > High
Depht Filtering > Aggresive
Calculate  points color  > tak

zaobserwować raportowane  etapy generowania 

10. Generowanie modelu pokrycia terenu DSM Workflow > Build DEM 
ustawienia: Geographic (zachowanie CRS 2180), 
Source > Dense Interpolation > Enabled
pozostałe parametry – bz
wyświetlić:  Workspace > Chunk > DEM 

11. Generowanie ortomozaiki wg DSM  Workflow > Build Orthomosaic
Projection: Geographis PL-1992 (2180)
Enable hole filling   √
pix size 0.10 m  (program proponuje ok. 11 cm )
pozostałe parametry – bz

12. Analiza ortomozaiki
wyświetlić orto: Workspace > Chunk > Orthomosaic 
w pasku ikon pojawia się Show Seamlines 

skąd biorą się małe poligony?
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Wykonać lokalną edycję linii mozaikowania : w obszarze wybranego małego poligonu narysować wielobok 
 Ortho > Draw polygon , PKM Assign Images
i sprawdzić, czy spośród ortoobrazów nie było korzystniejszego niż wybrał program.

13. Eksport ortomozaiki i ortoobrazów DSM
zapis w katalogu D > CFL_users
File > Export > Orthomosaic > JPEG/TIFF/PNG
Tiff compression Jpeg,  q=90, x Tiled x Tiff overviews o Big    o Alfa 
pozostałe parametry – bz
---------
w katalogu D > CFL2 > orto-nu >  nazwisko  utworzyć katalog na ortoobrazy DSM
File > Export > Orthophotos
Tiff compression Jpeg, q=90, x Tiled x Tiff overviews
> All cameras
pozostałe parametry – bz
po OK wybrać katalog do eksportu

14. Wczytanie DTM  
U  tworzyć nowy pakiet danych  , jako kopia pakietu z 6. zdjęciami: Workspace  > Chunk > (PKM) > Duplicate 
ale nie kopiować Depth Maps, Dense Cloud, DEMs
jako aktywny Chunk wskazać  nowo utworzony (nazwać go np. 6 photo DTM-5 m)
File > Import DEM > DTM-5.tif

15. Generowanie ortomozaiki na DTM
  pix size  0.10 m 
pozostałe parametry - bz
Po wykonaniu wyświetlić orto: Workspace > Orthomosaic 
oraz wyświetlić linie mozaikowania Show Seamlines 
Sprawdzić czy linie mozaikowania przecinają budynki

16. Powtórne generowanie ortomozaiki na DTM
powtórzyć  zaznaczając opcję  Refine seamlines (Blending mode)
Sprawdzić czy linie mozaikowania przecinają budynki
Uruchomić  generalizację linii mozaikowania: Tools > Orthomosaic >  Generate seamline 
przy współczynniku 1.5 lub 2. Po tym zabiegu linie mozaikowania można wyeksportować do pliku:
 Export > Shapes (jako shp wraz z labels & attributes)

17. Eksport ortomozaiki i ortoobrazów DTM
zapis w katalogu D > CFL_users
File > Export > Orthomosaic > JPEG/TIFF/PNG
Tiff compression Jpeg, q=90, x Tiled x Tiff overviews o Big    o Alfa 
pozostałe parametry – bz
---------
w katalogu D > CFL2 > orto-nu >  nazwisko  utworzyć katalog na ortoobrazy DTM (inny niż w pkt. 13) 
File > Export > Orthophotos
Tiff compression Jpeg, q=90, x Tiled x Tiff overviews
x All cameras
pozostałe parametry – bz
po OK wybrać katalog do eksportu

18. Zapis wyników dla potrzeb opracowania projektu
należy zapisać raporty oraz ortomozaiki i ortoobrazy :
a) orto/DSM 
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b) orto/DTM z opcją refine seamlines 
oraz linie mozaikowania (shp) dla orto na DTM (przy opcji Refine) 

część B – orto ze zdjęć ukośnych   

I. Uruchomienie Metashape  
File >  wybrać projekt zapisany w części 1  (lub kontynuować projekt)
założenie nowe  j   pa  czki   danych  : Workspace> Add Chunk  (nazwa np. ukosne)

II. Wczytanie zdjęć Workflow > AddPhotos
wybrać zdjęcia zgodnie z tabelą 1 (jeden z katalogów): _EAST, _SOUTH, _WEST, _NORD

III. Podanie parametrów kamery/kalibracji Tools > Camera Calibration  
frame, pix=0.0068 [mm]; f=100 [mm]; 
Fixed parameters: All
Ograniczenie liczby niewiadomych jest korzystne przy pierwszej iteracji, do której ogranicza się ćwiczenie 
(wyrównanie bliku zdjęć ukośnych wykonanych z dużej wysokości jest zadaniem bardzo złożonym). 

IV. Podanie właściwości danych Reference > Reference Settings    
układ wsp (x3):  PL-1992 (2180);
dokładność EOZ: mx=my=1 m; mz=1.5 m (wpis 1/1.5);    typ kątów i dokładność (om-fi-ka, m =...)- nieistotne 
GCP: nieistotne, projekt będzie wykonany bez fotopunktów
dokładność tie mp =1 pix
śr. wys. fotografowania (capture distance) :   850  m

V. Import EOZ Reference > Import 
dane w > EOZ  (odpowiednio east, west, nord, south)
Należy wczytać tylko X,Y,Z środków rzutów, pominąć kątowe EOZ

VI.  Aero - formowanie sieci zdjęć metodą SfM  Workflow > Align Photos 
General: Accuracy > Hight; 
 Preselection > Reference/Generic 

 Reset current alignment 
Advanced: Key  point limit: 40000 
 Tie point limit:    4000   

Apply mask  Adaptive camera model fitting

Jeśli estymowane wartości EOZ mają b. duże błędy  tj. MXYZ > 5 m, a kąty om/fi nie są ok 0/45 lub 45/0 
z max odchyleniem do 10. stopni, to należy powtórzyć Align z nowymi ustawieniami
  Accuracy > Medium z aktywnym Reset current alignment 
Jeśli błędy dalej są duże to powtórzyć Align zmieniając dodatkowo:

Key  point limit: 20000 
 Tie point limit:    2000

Zmienić ustawienia kamery: Tools > Camera Calibration  
Fixed parameters:  cx,cy,k1,k2,k3,k4,b1,b2,p1,p2,p3,p4  (czyli obliczane będzie tylko f)
Uruchomić Optimize 

Optimize Camera Alignmnet , dopuścić liczenie  f

VII. Filtracja tie Model > Gradual Selection
> Reprojection Error – wykonać 2-3 iteracje, w każdej odfiltrować do 5% pkt ( po skasowaniu  > Optimize )
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VIII. Wczytanie DTM 
Wczytać model    File > Import DEM> DTM-5.tif

IX. Generowanie ortomozaiki 
 pix size  0.10 m 
zaznaczyć opcję  Refine seamlines (Blending mode)
Sprawdzić czy linie mozaikowania przecinają budynki

X. Eksport ortomozajki i ortoobrazów 
File > Export > Orthomosaic
Tiff compression Jpeg, q=90, x Tiled x Tiff overviews o Big    o Alfa 
pozostałe parametry – bz

w katalogu D>CFL_users  utworzyć katalog na ortoobrazy
File > Export > Orthophotos
Tiff compression Jpeg, q=90,                           x Tiled                   x Tiff overviews                   o Big    o Alfa 
pozostałe parametry – bz
po OK wskazać katalog do eksportu

XI. Zapis projektu
dla potrzeb opracowania projektu będą konieczne: raport Metashape,  ortomozaika  oraz linie mozaikowania 
(shp)

część C –  Opracowanie wyników

Pola martwe na orto-obrazach

Dotyczy ortoobrazów ze zdjęć pionowych z modelem DSM. Wybierając do analizy  obszar pokrycia dwóch ortoobrazów 
należy przedstawić  ile pól martwych występuje na jednym, drugim a ile jest po ich złączeniu.  Do badania wybrać  
ortoobraz wykonany ze zdjęcia środkowego  w szeregu oraz jego odpowiednik z drugiego szeregu. 

Sposób wykonania: dodać ortoobrazy algebraicznie  (wybrany kanał RGB, np. B). Przyciąć „suma”, „orto1” i „orto2” do 
prostokąta (z wykluczeniem marginesów bez tekstury). I

Określić ile jest  pikseli reprezentujących pola martwe w obrazach „suma”, „orto1” i „orto2” oraz jaki jest ich udział w 
stosunku do całego obrazu. 

Do wykonania zadania potrzebne narzędzie GIS które pozwala przyciąć obraz do tego samego obszaru prostokątnego, 
podać ile jest pikseli o poszczególnych jasnościach; wykonać algebrę map.

W przypadku QGIS: 

• algebra map: Raster> kalkulator

• przycięcie: Raster > Cięcie > Przytnij raster do zasięgu (pierwsze wycięcie > wybierz zasięg w widoku; kolejne 
dwa wycięcia: użyj zasięgu warstwy)

• liczba pikseli 255 lub 510: Processing > Raster analiza > Raport unikalnych wartości

Konflikty linii mozaikowania

Dotyczy ortomozaiki ze zdjęć pionowych i ukośnych uzyskanych dla  modelu DTM-5 (w obu wypadkach gdy była 
włączona opcja Refine seamlines). Konflikt oznacza przecięcie przez linię mozaikowania budynku lub drzew. Ocenić 
wizualnie, sformułować wniosek w jakich sytuacjach najczęściej występują, pokazać jeden przykład dla obu 
ortomozaik. 

Mapa przeglądowa mozaikowania

KPyka,  GiFT > CFL > Orto w Metashape                                   18.01.2021 5



Dotyczy orto ze zdjęć pionowych dla  modelu DTM-5.

Mapa ma pokazywać przebieg linii mozaikowania, nazwy ortoobrazów wewnątrz obszarów ograniczonych liniami, na 
tle ortomozaiki. Aby uzyskać taki efekt należy poddać edycji linie mozaikowania (wraz z innymi danymi) 
wyeksportowane do pliku shp.

Pokrycie podłużne i poprzeczne 

Określić średnie pokrycie podłużne i poprzeczne zdjęć pionowych oraz ukośnych 

Dokładność ortoobrazów i ortomozaik

Oszacować dokładność orto-obrazów/dtm5 ze zdjęć pionowych przez porównanie położenia co najmniej 10 punktów
załamania konturów budynków względem BDOt10k. Do pomiaru wybierać takie miejsca na orto-obrazach w których
widać  przyziemia  budynków.  Punkty  powinny  być  rozmieszone  w  miarę  równomiernie  na  obszarze  ortomozajki.
Zestawić różnice dX i dY w tabeli oraz podać wartość średnią, średni błąd kwadratowy wsp. X i Y oraz położenia XY
(RMSEx, RMSEx, RMSExy), wraz z mapką prezentującą położenie punktów w obszarze ortomozajki. Ustosunkować się
do występowania czynnika systematycznego odchyłek.

Oszacować dokładność ortomozajek/dsm ze zdjęć pionowych oraz ortomozajek/dtm5 z ukośnych przez porównanie
położenia co najmniej 10 szczegółów względem ortomozajki/dtm5 ze zdjęć pionowych. Zestawić różnice dX i dY w
tabeli oraz podać wartość średnią, średni błąd kwadratowy wsp. X i Y  oraz położenia XY (RMSEx, RMSEx, RMSExy).
Ustosunkować się do występowania czynnika systematycznego odchyłek.

Sprawozdanie

Opracować sprawozdanie,   wpierw krótko opisać co było przedmiotem  projektu (  tekst ok.  2500-3000  znaków)  
a następnie zamieścić wyniki badania pól martwych i konfliktów linii mozaikowania (nie załączać raportów Metashape).
Na końcu podsumowanie oparte na uzyskanych z ćwiczenia doświadczeniach. 

Przesłać sprawozdanie w pliku: cfl-orto-mshp-nazwisko.pdf 

Załączniki – rozdział danych↓ 
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Tabela 1. Przydział zdjęć

Student Pomocnicze numery 
zdjęć pionowych 
(właściwe  w tabeli2)

Zdjęcia  
ukośne

Student Pomocnicze numery 
zdjęć pionowych 
(właściwe  w tabeli2)

Zdjęcia  
ukośne

1. 1,2,3,6,7,8 east 16 7,8,12,13,18,19 east

2. 2,3,4,7,8,9 south 17 8,9,13,14,17,18 south

3. 3,4,5,8,9,10 west 18 21,22,23,26,27,28 west

4. 4,5,9,10,14,15 nord 19 22,23,24,25,26,27 nord

5. 6,7,8,11,12,13 east 20 25,26,27,30,31,32 east

6. 7,8,9,12,13,14 south 21 21,28,29,22,27,30 south

7. 8,9,10,13,14,15 west 22 22,27,30,23,26,31 west

8. 9,10,14,15,17,16 nord 23 23,26,31,24,25,32 nord

9. 11,12,13,18,19,20 east 24 22,27,23,26,24,25 east

10. 12,13,14,17,18,19 south 25 27,30,26,31,25,32 west

11. 13,14,15,16,17,18 west 26 2,3,4,7,8,9 nord

12. 3,4,8,9,13,14 nord 27 3,4,5,8,9,10 east

13. 2,3,7,8,12,13 east 28 4,5,9,10,14,15 west

14. 1,2,6,7,11,12 south 29 6,7,8,11,12,13 nord

15. 6,7,11,12,19,20 west 30 7,8,9,12,13,14 east

Tabela 2. Przyporządkowanie zdjęć pionowych do numerów pomocniczych

Nr pomocnicze Zdjęcie Nr pomocnicze Zdjęcie
1 011_1722.tif 17 014_1880.tif
2 011_1723.tif 18 014_1881.tif
3 011_1724.tif 19 014_1882.tif
4 011_1725.tif 20 014_1883.tif
5 011_1726.tif 21 036_0607.tif
6 012_1791.tif 22 036_0608.tif
7 012_1792.tif 23 036_0609.tif
8 012_1793.tif 24 036_0610.tif
9 012_1794.tif 25 037_0645.tif

10 012_1795.tif 26 037_0646.tif
11 013_1848.tif 27 037_0647.tif
12 013_1849.tif 28 037_0648.tif
13 013_1850.tif 29 038_0679.tif
14 013_1851.tif 30 038_0680.tif
15 013_1852.tif 31 038_0681.tif
16 014_1879.tif 32 038_0682.tif
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